В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
yaroslav198395
yaroslav198395
11.08.2022 11:29 •  Информатика

Известна успеваемость 13 учеников класса по 10 предметам, напишите программу с которой определяется сколько в классе хорошистов. заранее !

Ответ:
Josoy
Josoy
04.10.2020 16:29
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  // заполним информацию случайным образом;
  // если хорошистов в результате не окажется,
  // просто перезапускаем задачу
  randomize;
  var a:=MatrRandom(13,10,4,5); // везде только 4 и 5
  for var i:=1 to 20 do // раскидаем 20 троек
    a[Random(13),Random(10)]:=3;
  a.Println(2); Writeln;
  // собственно, решение
  var k:=0;
  foreach var r in a.Rows do
    if r.All(x->x<>3) and not r.All(x->x=5)  then k+=1;
  Writeln(k,' хорошистов')
end.

Пример
5 5 4 4 4 5 3 3 4 4
 5 4 4 4 3 4 5 5 4 5
 5 5 5 3 5 4 4 5 5 4
 3 5 4 3 4 4 5 5 5 3
 5 3 4 4 5 4 4 5 5 4
 3 5 5 5 5 4 4 4 4 3
 4 4 5 3 5 4 4 5 4 5
 4 5 4 4 4 4 4 4 5 4
 3 5 3 4 4 4 4 4 5 3
 5 5 4 5 4 4 4 5 4 5
 4 5 4 5 4 5 3 4 5 5
 4 5 4 4 4 4 5 4 4 5
 4 3 5 4 4 4 5 5 3 5

3 хорошистов
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?