В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sergejkochetko
sergejkochetko
13.02.2023 23:53 •  Информатика

Информатика ! : напишите программу на паскаль с которой можно вычислить сумму и количество всех двузначных четных чисел.(цикл while). заранее я вроде разбираюсь в инфе, но что-то эту никак не ​

Ответ:
mayorovagelya
mayorovagelya
29.05.2020 16:17

program raf105;

var a,sum,col:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы узнать результат введите 0');

a:=1;

while a<>0 do

begin

 readln(a);

 if (10<=a) and (a<=99)

   then if a mod 2 = 0

     then

     begin

     sum:= sum+a;

     col:= col+1

     end;

end;

writeln('Количество чётных двузначных чисел: ',col);

writeln('Их сумма: ',sum);

end.

Написано на языке PascalABC.NET

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?