В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Машаrobotg
Машаrobotg
20.04.2020 03:22 •  Информатика

Напишите программу ввести два натуральных числа n и m . если m > n , то вывести m − n строк, в каждой строке выводятся числа от n до m число раз, соответствующее выводимому числу. например, для n = 3 и m = 6: 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6

Ответ:
vshapovalova21
vshapovalova21
08.09.2020 13:58
Var m,n,i,j:longint;
begin
readln(n,m);
if m > n then begin
for i:= n to m do begin
for j:= 1 to i do begin
write(i,' ');
end;
writeln;
end;
end else begin
for i:= m to n do begin
for j:= 1 to i do begin
write(i,' ');
end;
writeln;
end;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?