В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
toroshinaalena
toroshinaalena
17.12.2020 05:35 •  Информатика

Написать программу на pascal "дана строка символов s, состоящая максимум из 250 символов. напишите программу, которая проверит является ли строка s палиндромом. примеры палиндромов: ‘cojoc’, ‘cazac’, ‘potop’, ‘rotor’."

Ответ:
PomoGayka0
PomoGayka0
04.10.2020 16:15
Var
s:string;
l,i:byte;
begin
readln(s);
l := length(s);
for i:= 1 to l div 2 do begin
if s[i] <> s[l-i+1] then begin
writeln('NO');
halt;
end;
end;
writeln('YES');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?