В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
1FACE1
1FACE1
09.04.2020 06:21 •  Информатика

Нужно написать программу на языке паскаль условие такое: вводится 15 чисел определить каких чисел кратных трём больше положительных или отрицательных

Ответ:
розасит2006
розасит2006
04.10.2020 15:29
Var a,p,n,i:integer;
begin
 p := 0;
 n := 0;
 for i := 1 to 15 do
  begin
  read(a);
  if a mod 3 = 0 then
    if a > 0 then p := p + 1
    else
    if a < 0 then n := n + 1
  end;
  if p > n then writeln('Положительных') else
  if p < n then writeln('Отрицательных') else
    writeln('Одинаково')
end.

{вариант "как-то посложнее"}

var a,i,s:integer;
begin
 s := 0;
 for i := 1 to 15 do
  begin
  read(a);
  s := s + ord(a mod 3 = 0) * (ord(a > 0) - ord(a < 0))
  end;
 if s > 0 then writeln('Положительных') else
 if s < 0 then writeln('Отрицательных') else
 writeln('Одинаково')
end.   
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?