В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zuhraafokinazuhra
zuhraafokinazuhra
10.04.2023 14:31 •  Информатика

Информатика 9 класс.составьте программу которая формирует массив из 16 случайных целых чисел от -20 до 20 и находит элемент с нулевым значением

Ответ:
dreamnazym
dreamnazym
04.10.2020 15:09
// PASCAL

var
  a: array [1..16] of integer;
  i: integer; b: boolean;

begin
  randomize;
  for i := 1 to 16 do a[i] := random(-20, 20);
  for i := 1 to 16 do
    if a[i] = 0 then begin
      if b then write(', ');
      write(i, '-й ');
      b := true;
    end;
  if b then writeln('элемент(ы) равен(ны) нулю') else writeln('В массиве нету элементов, равных нулю.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?