В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

1)вычислить сумму четных и нечетных элементов(также в массиве). 2)вычислить количество "0" в массиве. написать программу в pascal. p.s.: можно сделать одну из двух.

Ответ:
Tema228328
Tema228328
04.10.2020 14:52
Program sum_nechet;
var a: array [0..100] of integer;
var b,i,c,k:integer;
begin
    randomize;
    for i:=1 to 10 do
    begin
        a[i]:=random(10);
        writeln(a[i]); // Это можно не писать, просто чтобы видеть числа в массиве, если интересно.
    end;
    c := 0;
    b := 0;
    for i:=1 to 10 do
    begin
        if a[i] mod 2 = 0 then
        b := b + a[i]
        else
        c := c+ a[i];
    end;
    writeln('Нечетных ' , c);
    writeln('Четных ' , b);
    k:=0;
    for i:=1 to 10 do
    begin
        if a[i] = 0 then
        k:= k+1
    end;
    writeln('Нулей ' , k)
end.
       
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?