Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Алтынбек05
06.12.2022 18:34 •
Информатика
Разработать алгоритм и программу вычисления квадратов и кубов целых чисел от 1 до 50. результат выдать на экран в виде таблицы: x x2 x3
Ответ:
Polina8472
08.09.2020 13:35
// PascalABC.NET 3.2, сборка 1345 от 24.11.2016
// Внимание! Если программа не работает, обновите её версию!
begin
Writeln(' x x^2 x^3');
for var i:=1 to 50 do Writeln(i:3,i*i:5,i*i*i:8);
end.
Результат
x x^2 x^3
1 1 1
2 4 8
3 9 27
4 16 64
5 25 125
6 36 216
7 49 343
8 64 512
9 81 729
10 100 1000
11 121 1331
12 144 1728
13 169 2197
14 196 2744
15 225 3375
16 256 4096
17 289 4913
18 324 5832
19 361 6859
20 400 8000
21 441 9261
22 484 10648
23 529 12167
24 576 13824
25 625 15625
26 676 17576
27 729 19683
28 784 21952
29 841 24389
30 900 27000
31 961 29791
32 1024 32768
33 1089 35937
34 1156 39304
35 1225 42875
36 1296 46656
37 1369 50653
38 1444 54872
39 1521 59319
40 1600 64000
41 1681 68921
42 1764 74088
43 1849 79507
44 1936 85184
45 2025 91125
46 2116 97336
47 2209 103823
48 2304 110592
49 2401 117649
50 2500 125000
0,0
(0 оценок)
Популярные вопросы: Информатика
dasha1832
28.02.2022 23:24
Сколько ячеек оперативной памяти необходимо для записи слова Экран...
ира1031
14.04.2023 02:03
Зашифруйте слово реактор при ключа 174...
bathory080904
01.07.2021 06:02
Представьте числа в восьмиразрядном формате без знака: 14, 89, 114 2. Представьте числа в 8-разрядном виде со знаком: +45, -45, +112, -112 3. Найдите десятичный эквивалент числе, записанным...
Kiri205
05.10.2021 04:13
19. Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну...
Tyxco
08.10.2020 20:12
Значение арифметического выражения 5^1200 +25^1000 - 5^100 записали в системе счисления с основанием 5. Сколько цифр «4» содержится в этой записи?...
xAlonerx
12.10.2020 17:30
восполнил пробелы в вариантами предлагаемым В выпадающих списках жанр Сказки о царе берендее литературная сказка поскольку у неёЧто такое графические редакторы Какова его функция ...
даша3648
28.09.2020 13:13
Информатика 10 класс Python Задание 1...
linaaaa2Li
20.03.2023 19:30
Заранее . решите . дано: a=ea₁₆ b=354₈ какое из чисел c, записанных в двоичной системе счисления, удовлетворяет неравенству a...
lol1046
20.03.2023 19:30
Дан массив x(7). найти номера нечётных элементов, стоящих на чётных местах (паскаль)...
аянаайши
24.05.2021 11:20
Дано число. определить чему равна сумма нечетных цифр в этом числе...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите её версию!
begin
Writeln(' x x^2 x^3');
for var i:=1 to 50 do Writeln(i:3,i*i:5,i*i*i:8);
end.
Результат
x x^2 x^3
1 1 1
2 4 8
3 9 27
4 16 64
5 25 125
6 36 216
7 49 343
8 64 512
9 81 729
10 100 1000
11 121 1331
12 144 1728
13 169 2197
14 196 2744
15 225 3375
16 256 4096
17 289 4913
18 324 5832
19 361 6859
20 400 8000
21 441 9261
22 484 10648
23 529 12167
24 576 13824
25 625 15625
26 676 17576
27 729 19683
28 784 21952
29 841 24389
30 900 27000
31 961 29791
32 1024 32768
33 1089 35937
34 1156 39304
35 1225 42875
36 1296 46656
37 1369 50653
38 1444 54872
39 1521 59319
40 1600 64000
41 1681 68921
42 1764 74088
43 1849 79507
44 1936 85184
45 2025 91125
46 2116 97336
47 2209 103823
48 2304 110592
49 2401 117649
50 2500 125000