Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
tamaragladysheva
12.01.2021 13:54 •
Информатика
Напишите программу которая для заданного числа определит сколько понадобится спичек чтобы выложить все цифры числа входные данные 1 239 результат 2 16
Ответ:
milanademidova1
04.10.2020 13:12
См. вложенный файл, программа в нём
0,0
(0 оценок)
Ответ:
артбар
04.10.2020 13:12
var a: array[0..9] of integer:=(6,2,5,5,4,5,6,3,7,6);
i,s: integer;
st: string;
begin
write('число: '); readln(st);
s:=0;
for i:=1 to length(st) do
s:=s+a[ord(st[i])-48];
writeln('число спичек = ',s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
njvbyf04Юля
11.09.2020 06:35
Вкорзине лежит 4 груши и 12 яблок .какое количество информации содержит сообщение о том,что из корзины достали грушу?...
MrKreeD1
23.02.2021 15:30
Перевести в двоичную систему счисления число 49,45. в случае необходимости дробную часть рассчитать с точностью до 4 знака включительно...
san11217
12.09.2020 02:02
Решите уравнение 32^х+3 байт = 256^х мб...
Rhhufyko
05.10.2021 03:43
Написать на pascal программу. определить ,являеться ли число n четным двузначным числом...
irinakol30p00rgy
25.12.2021 02:52
Как называются комплекс средств, состоящих из мониторной системы, набора программ и элементов графического интерфейса?...
Хурем
24.11.2020 15:33
Что такое компьютерная информатика?...
Dorefi
26.06.2020 10:20
Вмассиве целых чисел найти группу наименьшей длины, которая состоит из убывающей последовательности четных цифр написать код в с++...
БОГДАН111153748854
26.06.2020 10:20
Дано целое четырёхзначное число. используя операции div и mod найти произведение его цифр...
alsu1401
29.04.2020 08:49
Pascal: введите число а (пятизначное). вывести среднее арифметическое цифр числа a....
настя8412
29.04.2020 08:49
Что будет выведено на экран после исполнения фрагмента программы int i, j; for(j = 1; j 3; j++) { i = 0; while((i += 8) = 20) printf( %d , j + ; }...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,s: integer;
st: string;
begin
write('число: '); readln(st);
s:=0;
for i:=1 to length(st) do
s:=s+a[ord(st[i])-48];
writeln('число спичек = ',s);
end.