В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KotekaClient
KotekaClient
20.03.2020 03:05 •  Информатика

1.дано целое число. составить программу, определяющую, какое число было введено: положительное, отрицательное или ноль 2. вводятся два числа. сравнить эти числа.

Ответ:
elizavetachery
elizavetachery
04.10.2020 13:01
#include <iostream>
#include <conio.h>
void main() {
    int digit;
    std::cin >> digit;
    if(digit>0) {
       std::cout << "+" << std::endl;    
    } else if (digit<0) {
        std::cout << "-" << std::endl;    
    } else {
        std::cout << "0" << std::endl;        
    }
    
    int digit1, digit2;
    std::cin >> digit1;
    std::cin >> digit2;
    if(digit1>digit2 && digit1 !=0 && digit2 !=0) {
         std::cout << digit1 << " > " digit2 << std::cout;
    } else {
          std::cout << digit1 << " < " digit2 << std::cout;
    }
_getch();
return 0;
    
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?