В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
slavaapakinp00lrn
slavaapakinp00lrn
03.07.2022 08:14 •  Информатика

Составьте программу, которая заполняет массив а 1..0 случайными целыми числами в диапазоне от 1 до 10 и вычесляет сумму элементов массива с четными значениями

Ответ:
star666
star666
04.10.2020 12:58
Program ex;

const
g = 100;

var
a, i, sum: integer;
b: array[1..g] of integer; // Не совсем понятен был размер массива. Мною было принято решение задать значение 100. Вы можете изменить его в любое время.
// Поменяв значение в константе g.
begin
sum := 0;
for i := 1 to g do 
begin
a := random(1, 10);
b[i] := a;
if b[i] mod 2 = 0 then
sum := b[i] + sum;
end;
write('Сумма массивов с четными значениями: ', sum)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?