В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bahromt1999200
bahromt1999200
02.10.2020 04:01 •  Информатика

Написать программу, в которой вводится последовательность целых чисел, оканчивающаяся нулем (т.е. признак окончания ввода чисел в последовательности – ввод нуля). программа должна посчитать и вывести количество отрицательных чисел в этой последовательности. программу реализовать двумя при цикла с пред- и пост- условием.

Ответ:
070520031
070520031
08.09.2020 12:58
Var
    number: integer;
    k: integer;

begin
    repeat
        write('number = ');
        readln(number);
        
        if number < 0 then k := k + 1;
    until number = 0;
    
    writeln('Кол-во отрицательных = ', k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?