В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
fari85851
fari85851
02.10.2020 04:01 •  Информатика

Напишите программу на pascal. задан массив b[10]. заполнить массив случайными числами(-10..10). вывести на экран в строчку через пробел. вычислить сумму всех элементов массива и кол-тво чисел кратных двум.

Ответ:
archibasovav
archibasovav
04.10.2020 12:31
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var b:=ArrRandom(10,-10,10); b.Println;
  Writeln('Сумма элеменов массива равна ',b.Sum);
  Writeln('Количество четных чисел равно ',b.Count(x->x.IsEven))
end.

Пример
1 10 3 -4 -10 -1 -6 0 -4 9
Сумма элеменов массива равна -2
Количество четных чисел равно 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?