В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
205ячсмит
205ячсмит
11.06.2021 20:25 •  Информатика

Составьте программу, которая позволяет ввести элементы массива а с клавиатуры и выводит на экран количество отрицательных элементов и их индексы. p.s. не надо искать ответ в инете, т.к. там не правильно

Ответ:
1шрус220
1шрус220
04.10.2020 12:19
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var a:=ReadArrInteger('Введите 10 чисел, нажмите Enter'+#13#10,10);
  var t:=a.Select((x,i)->(x,i+1)).Where(x->x[0]<0);
  Write('Отрицательных- ',t.Count,'; их номера ');
  t.Select(x->x[1]).Println
end.

Пример
Введите 10 чисел, нажмите Enter
 3 14 0 -13 6 -11 -4 0 7 12
Отрицательных- 3; их номера 4 6 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?