В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Alexey2005201937
Alexey2005201937
23.01.2023 11:25 •  Информатика

Задана площадь и диагональ прямоугольника. составьте программу, с которой определите периметр прямоугольника.

Ответ:
kartew
kartew
04.10.2020 12:17
\displaystyle d^2=a^2+b^2 \to a^2=d^2-b^2; \\ S=ab; \ S^2=a^2b^2=(d^2-b^2)b^2 \\ b^4-b^2d^2-S^2=0; \ b^2 \to x; \ x^2-d^2x+S^2=0 \\ D=d^4-4S^2, \ D \geq 0 \\ x_1= \frac{d^2-\sqrt{d^4-4S^2}}{2} ; \ b= \sqrt{x}; \ a=S/b \\
P=2(a+b)=2\left( \frac{S}{b}+b\right)

// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var d:=ReadReal('Диагональ прямоугольника');
  var S:=ReadReal('Площадь прямоугольника');
  var Di:=sqr(d*d)-4*S*S;
  if Di<0 then Writeln('Неверные данные')
  else begin
    var b:=sqrt((d*d-sqrt(Di))/2);
    var P:=2*(S/b+b);
    Writeln('P=',P:0:4)
    end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?