В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vipnikita20199
vipnikita20199
16.03.2023 15:16 •  Информатика

Решить. напишите программу формирования массива размером 5х5 с датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки. выведите на экран исходный и измененный массив. (паскаль абс) с объяснением

Ответ:
SuperSanii
SuperSanii
08.09.2020 12:50
Const
n=5;
var
a:array[1..n,1..n] of integer;
i,j:integer;

begin
//генератор случайных чисел. Диапазон от 1 до 10.
 for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    a[i,j]:=random(10)+1;
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Проверка условия и переприсвоение, если верно.
 for i:=1 to n do
  for j:=1 to n do
   begin
    if (((i+j) mod 2)=0) then
     a[i,j]:=a[1,2];
   end; 
 
//Вывод полученного массива.
  for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Ожидание.
readln();
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?