В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу на паскаль: 1) составить программу, которая при заданных значениях x и y вычисляет функции a с точностью 10^-3 a=((x*y)/(x+y))/(1+√(x²-x-4)); 2) составить программу, которая запрашивает ввод коэффициентов a,b,c,d уравнение вида "ax+b=c+dx", а после ввода коффициентов напечатает или решение или сообщение о том, что решение не существует, коэффициенты уравнения вводятся в соответствии одному из этих случаев.

Ответ:
saha1710
saha1710
04.10.2020 11:47
1) Точность вычисления в программе не задается. Указано только количество цифр дробной части (3), которое требуется вывести на экран.
var x,y,a:real;
begin
write('x = ');
readln(x);
write('y = ');
readln(y);
if x*x-x-4>=0 then
 begin
 a:=((x*y)/(x+y))/(1+sqrt(x*x-x-4));
 writeln('a = ',a:5:3);
 end
 else writeln('Корень из отрицательного числа');
end.

2)
var a,b,c,d:real;
begin
writeln('Введите a, b, c, d:');
readln(a,b,c,d);
if (a=d)
 then if (c=b) then writeln('Бесконечно много решений')
               else writeln('Решения нет')
 else writeln('x = ',(c-b)/(a-d));
end.

Пример:
Введите a, b, c, d:
2 1 4 3
x = -3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?