Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
mailiiti63
08.12.2021 02:25 •
Информатика
Вычислить среднее арифметическое положительных элементов массива
Ответ:
орион12
04.10.2020 11:39
var a:array[1..10] of integer;
i,k,s:integer;
begin
s:=0;
k:=0;
for i:=1 to 10 do
readln(a[i]);
for i:=1 to 10 do
if a[i]>0 then begin
s:=s+a[i];
k:=k+1;
end;
writeln(s/k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vhbhvgh
27.06.2020 08:50
Решить задачу через паскаль задача : Составить программу вычисления функции: Y=x2(x2+1), рассчитать для х=6....
maina342
08.05.2020 04:49
1.запишите полный путь файлу readme.txt, если известно, что он хранится папке help, вложенной папку home, находящейся на диске d: ....
liza10pav
08.05.2020 04:49
Определить какое количество страниц займёт текст, если всего в памяти компьютера он занимает 1 кбайт. в тексте используется 16 символьный алфавит. на одной странице...
Алексей08032005
08.04.2023 03:18
Какая документация подготавливаются при создании компьютерной игры...
Khmelnitskaya
14.09.2021 16:32
Плагиат туралы малимет 2,3 сойлем...
Dimasik333000
09.10.2020 07:54
Зробіть припущення щодо подібності загальних рис природи визначених вами країн та України. Назвіть їх....
sukalovan0
11.08.2020 09:25
В трех мешках 154,7 кг капусты.Сколько капусты в каждом мешке если в первом 2/7 всей капусты а во втором в 2,1 раза больше чем в первом ОЧЕНЬ...
Jojo11wye
05.10.2022 21:32
Расставте порядок действий и решите пример 3 ц 24 кг + 5 1/2 ц + 4ц 75 кг...
nezervillager
05.10.2022 21:32
Можете ответить на все вопросы на проверьте свои знания...
Вадим363737466
05.10.2022 21:32
Используя теорему о внешнем угле треугольника, найди угол О....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,k,s:integer;
begin
s:=0;
k:=0;
for i:=1 to 10 do
readln(a[i]);
for i:=1 to 10 do
if a[i]>0 then begin
s:=s+a[i];
k:=k+1;
end;
writeln(s/k);
end.