В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Aigggggg
Aigggggg
04.04.2020 16:37 •  Информатика

Составить программу, которая позволяет ввести рост n учащихся, найти средний рост учащихся и количество учеников с ростом выше (ниже)160 см?

Ответ:
oforange
oforange
04.10.2020 11:19
Int n;
cin >> n;
int counter = 0;
int sum = 0;
int curr;
for (int i = 0; i < n; i++) {
cin>>cur;
if (curr >= 160) {
sum += curr;
counter++;
}
}

cout<<"количество"<<counter<<endl;
cout<<"средный"<<(sum / (double) counter) << endl;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?