В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Elisavettas
Elisavettas
13.11.2020 02:02 •  Информатика

Написать программу на паскале для определения числа членов ряда,вошедших в сумму.исходные данные 0.62,точность вычисления 10^-4.

Ответ:
sh0d1
sh0d1
31.08.2020 13:52
Const eps=1e-4;
var n,z:integer; x,sx,an,s:real;
begin
x:=0.62;
sx:=sin(x);
n:=1; z:=-1; 
an:=1; s:=0;
while abs(an)>eps do
 begin
 z:=-z;
 n:=n+1;
 an:=z*sx/(n*(n*n-1));
 s:=s+an;
 end;
writeln('k = ',n-1,' s = ',s);
end.

Результат:
k = 17 s = 7.92376332816429E-002
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?