В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
eandrukova567
eandrukova567
26.11.2021 11:10 •  Информатика

1. написать программу которая ищет n! (цикл while)2. написать программу, которая находит число р = (1-1/2)(1-1/3)**(1-1/n). n вводится с клавиатуры. (цикл for)

Ответ:
провпр
провпр
29.05.2020 12:06

Объяснение:

1.

var

 k:integer;

 p:integer;

 n:integer;

begin

 readln(n);

 

 p:=1;

 k:=1;

 

 while (k <= n) do begin

   p:=p*k;

   k:=k+1;

 end;

 

 writeln(p);

 

end.

2.

var

 k:integer;

 p:real;

 n:integer;

begin

 readln(n);

 

 p:=1;

 

 for k:=2 to n do begin

   p:=p*(1 - (1/k));

 end;

 

 writeln(p);

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?