Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
milanagorbovsk
30.06.2020 13:23 •
Информатика
Написать программу которая считает количество цифр в числе и их сумму. паскаль. число вводится с клавиатуры
Ответ:
smarika83
04.10.2020 10:26
Для натуральных чисел:
var a,k,s:integer;
begin
write('a = ');
readln(a);
k:=0; s:=0;
while a>0 do
begin
k:=k+1;
s:=s+a mod 10;
a:=a div 10;
end;
writeln('k = ',k,', s = ',s);
end.
Пример:
a = 352186
k = 6, s = 25
0,0
(0 оценок)
Популярные вопросы: Информатика
янина1511
03.12.2022 04:33
Исполнитель Калькулятор преобразует число на экране. У исполнителя есть две команды, которым присвоены номера: 1. Прибавить 1 2. Умножить на 2 Программа для исполнителя...
Macsoneo
11.08.2022 08:38
Для обеспечения быстрого доступа ко всем открытым окнам...
danlestern
26.09.2021 00:05
1. текст в кодировке unicode занимает 3 кбайт памяти. сколько символов в тексте? 2. текст в кодировке ascii занимает 5 страниц. на каждой странице 25 строк по 40 символов...
Fanny321
08.11.2020 07:09
Https://thriveglobal.com/authors/365-dni-days-2020-hd-full-movie-online-free-1 https://thriveglobal.com/authors/123movies-365-dni-days-hd-full-watch-online-free https://thriveglobal.com/authors/full-watch-365-dni-days-2020-online-hd-free-1...
AkaNika
23.03.2022 09:24
Мазмұн дегеніміз не?Мазмұнының қандай түрлерін білесің?Мазмұн қалай құрылады?Мазмұнды жаңалау үшін не істеу қажет?Мазмұнды жою үшін қандай әрекеттерорындалады?...
Xomawq
28.03.2021 06:41
8. Розділові знаки розставлено правильно в усіх реченнях, ОКРІМ A Шумлять столітні дуби, тихо шепоче очерет навколо рукотвор-ного ставка (О. Олексенко).БІ досі тут ростуть...
emesiemesi95
07.01.2021 11:38
как сказать ( или настроить некие правила ) другу (который плохо на тебя влияет ) что не хочешь с ним общаться но не обидеть...
Lybava13322131
24.05.2022 08:45
Середнє арифметичне чисел 1,8. Перше число 3,25. Знайди друге число....
schastlivaya999
17.07.2021 06:02
Во все времена дети перенимали опыт своих родителей, участвовали в делах семьи. Это им в жизни. Вот и Митраша с Настей не оказались беззащитными в тяжёлых условиях. Вам...
pavy1980
09.05.2022 08:04
У реченні Від усієї картини віє чимосьпісенним означальний займенникужито у відмінку...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,k,s:integer;
begin
write('a = ');
readln(a);
k:=0; s:=0;
while a>0 do
begin
k:=k+1;
s:=s+a mod 10;
a:=a div 10;
end;
writeln('k = ',k,', s = ',s);
end.
Пример:
a = 352186
k = 6, s = 25