В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nik180208mailru
nik180208mailru
22.11.2020 14:08 •  Информатика

Паскаль. нач. уровень.

числа фибоначчи определяются: f0=f1=1, fn=fn-1+fn-2, при n=2, (т.е. каждое последующее число равно сумме двух предыдущих). составить программу:
а) нахождения к-го числа фибоначчи
б) нахождение самого первого числа фибоначчи, превышающего м
в) вычисления суммы всех чисел фибоначчи, значения которых не превышают 1000.

Ответ:
Софамимими
Софамимими
11.08.2019 01:10

ответ:

как-то так:

var i, m : integer;

s: longint;

function fib(n: integer): longint;

begin

if n< 2 then fib: =1

else fib: =fib(n-1)+fib(n-2);

end;

begin

writeln('f(25)=',fib(25));

write('enter m: ');

readln(m);

i: =1;

while fib(i)< =m do

inc(i);

writeln('fib(',i,') = ',fib(i), ' > m=',m);

s: =0;

i: =1;

while (fib(i)< =1000) do

begin

inc(i);

s: =s+fib(i);

end;

writeln('sum = ',s)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?