Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Фея1011
16.06.2020 11:36 •
Информатика
Составить программу нахождения чисел от -100 до 100 кратных 7 pascal abc
Ответ:
qnorri
09.08.2020 08:27
Я взяла числа по модулю, иначе будет 0. Если тебя устраивает 0, тогда не пиши abs в условии.
var s,a: integer;
i:integer;
begin
a:=-101;
for i:=1 to 200 do begin
a:=a+1;
if a mod 7=0 then s:=s+abs(a);
end;
writeln (s);
end.
Выводит: 1470
0,0
(0 оценок)
Популярные вопросы: Информатика
metalnikovat
31.12.2022 02:52
X=195a:= x div 100b:= x mod 100c:= x mod 10s:=a+b+c...
лол1338
11.10.2022 22:50
Фотография занимает 32 Мб.Определить,,сколько таких фотографий вместится на флэшку 4 Гб? а)4096 б)128 в)320 г)1280...
dashusha0703
09.01.2022 16:19
Выбери компонент который не входит в состав интегрированной среды разработки программ ИнтерпретаторОтладчикИнкапсуляторРедактор кодаКомпилятор...
magmadi1
16.07.2022 23:58
Вычисли сколько раз выполнится данный цикл с параметром for i in range(1, 12, 2):36.2112...
tanya665444
08.09.2020 17:36
Производится четырехканальная звукозапись с частотой дискретизации 64 кГц и 32-битным разрешением. Запись длится 1 минуту. Найдите объем звукового файла в Мегабайтах....
olivka8
04.04.2022 22:35
сор по информатике сегодня...
arslando
06.03.2021 22:32
Производится четырёхканальная (квадро) звукозапись с частотой дискретизации 32 кГц и 32-битным разрешением. Запись длится 2 минуты, её результаты записываются в файл,...
Мика7771
01.03.2021 09:57
Дайте перевод текста how i became a witer. оч !...
варфэисник
01.03.2021 09:57
Мастер изготовил 295 деталии, перевыполнив план на восемьнадцать процентов . сколько деталии должен был изготовить мастер по плану ?...
Sultanasem2007
01.03.2021 09:57
Сочинение по произведению возвращение о великой отечественной войне...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var s,a: integer;
i:integer;
begin
a:=-101;
for i:=1 to 200 do begin
a:=a+1;
if a mod 7=0 then s:=s+abs(a);
end;
writeln (s);
end.
Выводит: 1470