В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ZaykaYmnik
ZaykaYmnik
19.10.2020 02:19 •  Информатика

Не могу написать программу на c# напишите программу которая определяет в заданном числе заданную цифру.\ цифра это числа от 0 до 9

Ответ:
Using System;

//Напишите программу которая определяет в заданном числе заданную цифру.
//Цифра это числа от 0 до 9

namespace NoNamespace {
    internal class Program {

        private static void Main() {
            Console.WriteLine(IsDigitInNumber(123.8, 2));
            Console.WriteLine(IsDigitInNumber(1, 1));
            Console.WriteLine(IsDigitInNumber(103.28, 2));
            Console.ReadLine();
        }

        private static int IsDigitInNumber(double number, uint digit) {
            if (0 > digit || digit > 9)
                throw new Exception("Не верный формат цифры");

            var n = number.ToString().IndexOf(digit.ToString());
            var p = number.ToString().IndexOf(".");
            //Console.WriteLine($"number = {number} digit = {digit} n = {n} p = {p} A = {p-n}");
            return p-n;
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?