В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kisonka14
Kisonka14
05.07.2021 23:21 •  Информатика

Необходима программа на языке паскаль в классе проведено тестирование. максимально можно было набрать 100 . известны , набранные каждым из учеников. определите, сколько учеников в классе набрали: , отклоняющиеся от среднего значения не более чем на 10%.

Ответ:
stiles1996
stiles1996
04.10.2020 10:13
Var a:array[1..100] of real;
i,k,n:integer;
sr,pr,s:real;
begin
write('Введите кол-во учеников в классе: '); readln(n);
writeln('Введите учеников: ');
for i:=1 to n do
read(a[i]);

s:=0;
for i:=1 to n do
s:=s+a[i];
sr:=s/n; pr:=sr/10;
for i:=1 to n do
if (a[i]<sr+pr) and (a[i]>sr-pr) then
inc(k);
writeln('Кол-во , отклоняющиеся от срзнач. не более чем на 10%: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?