В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Rukishka05
Rukishka05
14.07.2022 19:31 •  Информатика

Написать программу на паскале, которая для заданных x и n вычисляет: , где n=количество членов ряда.

Ответ:
Andriy1208
Andriy1208
09.08.2020 08:20
Var
    x, a, s: real;
    n, i: integer;

begin
    write('Введите x и n ');
    readln(x, n);
    
    a := 1;
    s := a;
    for i := 1 to n do
    begin
        a := a * (-1) * x * x / (2 * i - 1) / (2 * i);
        s := s + a;
    end;
    
    writeln('S = ', s:10:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?