В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
1234554321111
1234554321111
13.04.2022 20:48 •  Информатика

Составить программу, которая запоминает массив а () случайными числами от 1 о10 затем первый элемент меняет местами с максимальным элементом

Ответ:
Сонька2808
Сонька2808
08.09.2020 12:16
Var
  a: array [1..10] of integer;
  i, max, s, x: integer;

begin
 s:=1;
  randomize;
  for i := 1 to 10 do
  begin
    a[i] := random(10) + 1
  end;
  writeln(a);
max := a[1];
 
  for i := 1 to 10 do
  begin
    if max < a[i] then begin
      max := a[i];
      s := i
    end;
  end; 
  x := a[1];
  a[1] := a[s];
  a[s] := x;
    writeln(a)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?