В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ekaterrrrr
ekaterrrrr
12.07.2022 19:03 •  Информатика

1. написать программу, которая вычисляет сумму первых n четных положительных чисел. исходные данные (n – количество чисел) вводятся с клавиатуры. результаты работы программы записываются в файл out.txt. 2. написать программу, которая вычисляет сумму первых n четных положительных чисел. исходные данные (n – количество чисел) вводятся из файла input.txt. результаты работы программы добавляются в файл out.txt.

Ответ:
Erasylzhakanov
Erasylzhakanov
04.10.2020 09:08
  var a,b,sum,i:int64;  begin   assign (input,'input.txt');assign (output,'out.txt');   reset (input);rewrite (output);     readln(a);  b:=2;  i:=1;  repeat  begin  sum:=sum+b;  b:=b+2;  i:=i+1;  end;  until i=a+1;   writeln(sum);    end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?