В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kristinaлсп
kristinaлсп
27.05.2021 12:33 •  Информатика

Синформатикой: написать программу, которая в массиве размерностью в 10 на 12 находит сумму: 1)всех элементов массива. 2) каждого столбца. 3) каждой строки. 10

Ответ:
SekretKtoYa
SekretKtoYa
23.05.2020 22:20

const m=10; n=12;
var a:array [1..m,1..n] of integer;
i,j:integer;
sob:integer;
sst:array[1..n]of integer;
sstr:array[1..m]of integer;
begin
randomize;
for i:=1 to m do begin
for j:=1 to n do begin
a[i,j]:=random(10);
write(a[i,j]:3);
end;
writeln;
end;
sob:=0;
for i:=1 to m do begin
for j:=1 to n do begin
sob:=sob+a[i,j];
end;
end;
writeln('сумма всех элементов массива = ', sob);
writeln;
writeln;
for i:=1 to m do begin
sstr[i]:=0;
for j:=1 to n do begin
sstr[i]:=sstr[i]+a[i,j];
end;
end;
writeln('сумма элементов построчно');
for i:=1 to m do write(sstr[i]:3);
writeln;
writeln;
for j:=1 to n do begin
sst[j]:=0;
for i:=1 to m do begin
sst[j]:=sst[j]+a[i,j];
end;
end;
writeln('сумма элементов по столбцам');
for j:=1 to n do write(sst[j]:3);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?