Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Groverr
21.08.2021 04:46 •
Информатика
Pascal: вычислить значение выражения y=x^n – z^k. вычисление значения степени оформить в виде рекурсии.
Ответ:
карина2116
04.10.2020 07:52
Function Pow(x:real;n:integer):real;
begin
if n=0 then Pow:=1
else Pow:=Pow(x,n-1)*x
end;
var
x,z:real;
n,k:integer;
begin
Writeln('Введите x,n,z,k: '); Read(x,n,z,k);
Writeln(Pow(x,n)-Pow(z,k))
end.
Пример
Введите x,n,z,k:
3.7 5 2.18 4
670.85426424
0,0
(0 оценок)
Популярные вопросы: Информатика
User5281
25.02.2021 15:57
Какие изменения можно внести в изображении выполнив команды из меню Коррекция-Кривые...
DimitryPanika
28.11.2021 09:53
решить задачу по информатике программу написать на с++...
tanyalaim20061
27.07.2021 08:30
Нужно написать цифры в чертежнике (кумир) 85744....
shoma22
04.10.2020 12:59
Каким образом осуществляется управление компьютером с мыши?...
djuraev488
16.11.2020 19:55
Определите значение переменной s после выполнения следующих операторов: s: =10; for i: =1 to 4 do s: =s - i;...
maks8707
16.11.2020 19:55
Определите значение переменной s после выполнения следующих операторов: s: =10; for i: =1 to 4 do s: =s - i;...
mariii222
16.11.2020 19:55
Var a: integer; begin writeln( введите номер дня недели ); read(a); if a = 1 then writeln( понедельник ); if a = 2 then writeln( вторник ); if a = 3 then writeln( среда...
neste2
24.04.2023 02:17
Составьте программу рисования узора. Начальное положение робота отмечено символом. вариант 10...
Катюшасррсрсомлилм
07.01.2020 17:24
Какой из перечисленных аргументов опирается на теорию «функциональных возможностей человека»? Необходимо отозвать разрешение на вырубку леса в районе Z, так как недвижимость...
ulia200634
31.05.2020 11:11
Грамматикалық тапсырмалар 1.Берілген сөздерге фонетикалык талдау жасаңыз. нұсқа: әпкем...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
if n=0 then Pow:=1
else Pow:=Pow(x,n-1)*x
end;
var
x,z:real;
n,k:integer;
begin
Writeln('Введите x,n,z,k: '); Read(x,n,z,k);
Writeln(Pow(x,n)-Pow(z,k))
end.
Пример
Введите x,n,z,k:
3.7 5 2.18 4
670.85426424