Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
funisinfinity26
03.03.2023 06:52 •
Информатика
C#: для линейного целого массива a[n] найти сумму всех: а) чётных элементов; б) нечётных элементов; в) элементов, кратных 3.
Ответ:
blond48
04.10.2020 07:46
Using System;
public class Solution
{
public static void main(String[] args)
{
int n = int.Parse(Console.ReadLine());
int[] a = new int[n];
int sumch = 0;
int sumnech = 0;
int sumthree = 0;
for(int i = 0; i < n; i++)
{
a[i] = int.Parse(Console.ReadLine());
if (a[i] % 2 == 0) sumch =+ a[i];
if (a[i] % 2 != 0) sumnech =+ a[i];
if (a[i] % 3 == 0) sumthree =+ a[i];
}
Console.WriteLine("Сумма четных элементов массива: " + sumch);
Console.WriteLine("Сумма нечетных элементов массива: " + sumnech);
Console.WriteLine("Сумма элементов массива, кратных трем: " + sumthree);
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
студент168
29.12.2022 17:12
Какие утверждения справедливы для векторного кодирования рисунков? 1)рисунок разбивается на пиксели 2) это кодирование с набора фигур 3) это кодирование только с отрезков...
cleverprincess
12.01.2022 00:48
Числа-101,1000,1001,1011,110,1100,111 перевести в десятичную систему исчисления,а 10,11,1010,100 в двоичную...
Evdjr
04.11.2022 23:13
Надо дан массив, состоящий из целых чисел. напишите программу, которая выводит те элементы массива, которые являются чётными числами. входные данные сначала задано число...
Kassandriala
21.08.2020 14:41
Определить значение переменной b после выполнения следующего фрагмента программы, в котором a и b -нецелые переменные. a: =3 b: =3+11*a b: =b/2*a...
bogdanа
12.01.2021 08:30
для какого имени истинно высказывание первая буква согласная- вторая буква согласная ∧ последняя буква гласная Нужно построить таблицы для каждого имени...
AkvaH2O
23.01.2021 02:26
Ребят Запиши верные ответы. ( запиши данное число в двоичной, восьмеричной и шестнадцатеричной системе счисления) Системы счисления: Десятичная: 5Двоичная: Восьмеричная: Шестнадцатеричная: ответить!...
strong123
04.02.2020 20:53
Z=25 3*2+6/3/4*5-3...
VladBugorkov
15.05.2022 18:14
Метеорологическая станция ведет наблюдение за влажностью воздуха.результатом одного измерения является целое число от 0 до 100 процентов,которое записывается при минимально...
1Sinon12
04.03.2021 01:31
А) примеры образной информационной модели б) примеры знаковой информационной модели в) примеры смешанной информационной модели ))...
AFMaster
04.03.2021 01:31
Умный дятел гоша вот уже 10 часов без перерыва стучит по клавиатуре, набирая текст научной работы о видах вредителей хвойных деревьев и роли дятлов в полном избавлении от...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
public class Solution
{
public static void main(String[] args)
{
int n = int.Parse(Console.ReadLine());
int[] a = new int[n];
int sumch = 0;
int sumnech = 0;
int sumthree = 0;
for(int i = 0; i < n; i++)
{
a[i] = int.Parse(Console.ReadLine());
if (a[i] % 2 == 0) sumch =+ a[i];
if (a[i] % 2 != 0) sumnech =+ a[i];
if (a[i] % 3 == 0) sumthree =+ a[i];
}
Console.WriteLine("Сумма четных элементов массива: " + sumch);
Console.WriteLine("Сумма нечетных элементов массива: " + sumnech);
Console.WriteLine("Сумма элементов массива, кратных трем: " + sumthree);
}
}