В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
geliebtemutter
geliebtemutter
04.04.2022 20:39 •  Информатика

Написать программу в паскале 1.вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2,дано натуральное число n. вычислить (1+1/12)(1+1/22) … (1+1/n2). 3.дано целое число а. найти произведение целых чисел из промежутка от 1 до а

Ответ:
petr0poroshenko
petr0poroshenko
04.10.2020 07:40
1) 
var a,s,p,n,i:integer;

begin
readln(n);
s:=0; p:=1; a:=2;
for i:=1 to n do begin
p:=p*a;
s:=s+a;
a:=a+3;
end;
writeln(s,' 'p);
end.

2)

3)var a,p,i:integer;
begin
readln(a);
p:=1;
for i:=1 to a do
p:=p*i;
writeln(p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?