В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maria2005dp
maria2005dp
05.06.2020 22:51 •  Информатика

Чуваки, . не шарю совсем, надо написать программу и лучше с объяснениями. дано натуральное число. верно ли, что в данном числе нет данной цифры а (цифру а вводить с клавиатуры)

Ответ:
vikaraduga
vikaraduga
09.08.2020 07:51
Требуемая программа:
var n,a: longint; b: boolean;
begin
readln(n);
readln(a);
b:=false;
while n>0 do
 begin
 if n mod 10 = a then b:=true;
 n:=n div 10;
 end;
if b 
 then writeln('В числе есть введенная цифра')
 else writeln('В числе нет введенной цифры');
end.

Пример:
1236548
2
В числе есть введенная цифра
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?