В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
дира3
дира3
19.06.2021 03:35 •  Информатика

Составьте программу в pascal: компьютер задаёт случайное двухзначное число х, например 39; компьютер задаёт случайное однозначное число у, например 8; необходимо получить новое трехзначное число z, а именно 389т.е.число у вписать в середину х​

Ответ:
Сергей1901
Сергей1901
29.05.2020 09:09

var x,y,z:integer;

begin

   randomize;

   x:=1;

   repeat x:=random(100) until x>9;

   y:=random(10);

   z:=(x div 10)*100+y*10+(x mod 10);

   writeln('x=', x);

   writeln('y=', y);

   writeln('z=', z);

end.

0,0(0 оценок)
Ответ:
shapox
shapox
29.05.2020 09:09

program raf105;

var x,y,z:integer;

begin

x:=random(10,99);

writeln('Компьютер выбрал число ',x);

y:=random(1,9);

writeln('Компьютер выбрал число ',y);

z:= x mod 10;

x:= (x-z)*10;

z:= (x+z)+y*10;

writeln('Компьютер переместил второе число в середину первого. Результат: ',z);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?