В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vane12
Vane12
28.10.2021 17:33 •  Информатика

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [244143; 367821], числа, имеющие ровно 5 различных делителей. выведите эти делители для каждого найденного числа в порядке возрастания.

Ответ:
daniil069531671
daniil069531671
12.04.2019 18:00

uses crt;

var i,sum,k: integer;

begin

      sum: =0;

      k: =0;

      writeln('вводите числа. 0 - конец последовательности');

      repeat

          read(i);

          if i mod 2=1 then begin

              sum: =sum+i;

              inc(k);

          end;

      until i=0;

      writeln;

      writeln('среднее  арифметическое нечетных чисел: ',sum/k: 5: 3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?