Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Андрей11583
29.09.2020 08:12 •
Информатика
Cоставить программу в паскале. в одномерном массиве произвольных чисел вычислить произведение четных и нечетных элементов.
Ответ:
КитиКэт13
04.10.2020 06:34
Var a : array [1..10] of integer;
I, p1, p2: integer;
Begin
I:=1;
P1:=1; p2:=1;
For i := 1 to 10 do a[i] := random(10);
While i<=10 do begin
If i mod 2 <> 0 then p1:=p1 *a[i] else p2:= p2 * a[i];
I := i +1;
End;
Write(p1,' ',p2)
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
azz077
12.09.2020 19:38
Водной из кодировок unicode каждый символ кодируется 16 битами. определите размер следующего предложения в данной кодировке: как я любил твои отзывы, глухие звуки,...
kotik53Tv
02.09.2022 02:00
Векторлык графика дегенимиз не?...
АринаДаутова
05.06.2022 09:44
с Паскалем, он пишет: Program1.pas(10) : Встречено writeln , а ожидалось ; Программа: program z66; var k: integer; a, S: real; BEGIN writeln ( Подсчёт заработка...
ekaterina123sve
06.04.2023 04:19
No. Запишите единицы мерения информации в порядке убывания 1 Кбайт, 1025 байт, 1 Мбайт, 925 кбайт, 2мбайт...
aniavetisa
14.09.2022 05:41
Как выразить словами блок с ветвлением...
vlad200883
25.09.2021 14:30
Найди такое двузначное значение для переменной xx, чтобы после выхода из цикла переменная s s стала равна 18:18: s = 0 пока x 0 b = b + (x mod 10) x = x div...
ВенераРезанова
08.07.2022 10:56
Написать программу для ввода значения величины x целого типа, присваивания величине y действительного типа значения 5.5 , вычисления значения величины z=x-y и вывода...
LuсКу
08.07.2022 10:56
Какая часть указателя ресурса сети интернет указывает на протокол передачи? a) http: //; b) c) index.html; d) msu.ru/physics....
aizhanashoznweb
08.07.2022 10:56
Саша ездил с родителями в отпуск.3 дня он провёл в дороге.половину отпуска загорал и купался в море.в конце путешествия отправился с родителями в деревню,где пробыл...
vangok31
01.03.2022 04:49
Var n,s: integer; begin n: =0; s: =0; while s =35 do begin n: = n+1; s: =s+4 end; write(n) end. решите , надо с решением....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
I, p1, p2: integer;
Begin
I:=1;
P1:=1; p2:=1;
For i := 1 to 10 do a[i] := random(10);
While i<=10 do begin
If i mod 2 <> 0 then p1:=p1 *a[i] else p2:= p2 * a[i];
I := i +1;
End;
Write(p1,' ',p2)
End.