В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kessaa65
kessaa65
26.02.2022 11:57 •  Информатика

Написать программу на pascal,для вычисления значения функции f(x)= а) =0.5 при x-1 б)=0 при x=0 в)=x+3 при x< -1 x=[-3; 4] с шагом 0,5

Ответ:
vadimbukov
vadimbukov
04.10.2020 06:29
На самом деле условие F(х)=0 при х=0 лишнее, поскольку значение F(x)=0.5x² при x≥-1 и так дает F(0)=0.

var
  x,F:real;
begin
  x:=-3;
  while x<4.01 do begin
    if x<-1 then F:=x+3
    else F:=0.5*x*x;
    Writeln('x=',x:4:1,', F=',F:5:3);
    x:=x+0.5
    end
end.

Результат
x=-3.0, F=0.000
x=-2.5, F=0.500
x=-2.0, F=1.000
x=-1.5, F=1.500
x=-1.0, F=0.500
x=-0.5, F=0.125
x= 0.0, F=0.000
x= 0.5, F=0.125
x= 1.0, F=0.500
x= 1.5, F=1.125
x= 2.0, F=2.000
x= 2.5, F=3.125
x= 3.0, F=4.500
x= 3.5, F=6.125
x= 4.0, F=8.000
0,0(0 оценок)
Ответ:
DaNa1517
DaNa1517
04.10.2020 06:29
Var x:real;
begin
x:=-3;
while x<=4 do begin
 if x>=1 then writeln('F(x) = ',sqr(x)/2); 
 if x=0 then writeln('F(x) = 0');
 if x<-1 then writeln('F(x) = ',x+3);
x:=(x+0.5);
end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?