В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anion20
Anion20
13.02.2020 09:56 •  Информатика

Решить на паскаль с постусловием дано натуральное число m. написать программу для вычисления первой цифры числа m. входные данные 54321 выходные данные 5. дано натуральное число m. написать программу для вычисления второй цифры числа м(m> 10) входные данные 54321 выходные данные 4.

Ответ:
daniil539
daniil539
04.10.2020 05:18
Var
    m, i: integer;
    a: array[1..10] of integer;

begin
    readln(m);
    i := 0;
    repeat
        i := i + 1;
        a[i] := m mod 10;
        m := m div 10;
    until m = 0;
    
    writeln('Первая цифра ', a[i]);
    writeln('Вторая цифра ', a[i - 1]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?