В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
milashenko005
milashenko005
09.12.2022 02:04 •  Информатика

Напишите программу вычисления суммы чисел кратных 5 из натурального ряда чисел от 1 до n , и произведение чисел кратных к 3 (while)

Ответ:
787363
787363
25.08.2020 21:12
Uses crt; 
var n,s1,s2,i:integer; 
begin 
s1:=0;  s2:=0;   
writeln('Введите N');   
read(n);   
for i:=1 to n do   
if (i mod 5=0) then      
begin     
s1:=s1+i;     
end;     
inc(i);   
for i:=1 to n do   
if (i mod 3=0) then     
begin     
s2:=s2+i;     
end;     
inc(i);   
writeln('Сумма чисел кратных 5= ',s1);   
writeln('Сумма чисел кратных 3= ',s2); 
end.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?