В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Mysteryon
Mysteryon
16.08.2020 11:33 •  Информатика

Паскаль! напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Ответ:
Морго11
Морго11
04.10.2020 04:19
Var
  n,i:integer;
  s:string;
begin
  Write('Введите натуральное число: '); Read(n);
  Str(n,s);
  for i:=2 to Length(s) do
    if s[i]=s[i-1] then begin
      Writeln('Пара одинаковых цифр-соседей ',s[i]);
      Exit
      end;
  Writeln('В числе нет цифр, имеющих таких же соседей')
end.

Пример
Введите натуральное число: 375422453
Пара одинаковых цифр-соседей 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?