В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
anton2015b
anton2015b
11.05.2021 21:53 •  Информатика

Написать программу вычисления суммы кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных

Ответ:
PоLinaKozloVa
PоLinaKozloVa
04.10.2020 04:05
var
  i, s, p :integer;
begin
write ('n=');
readln (n);
s:=0;
p:=1;
  for i:=1 to n do
    begin
     if i mod 5=0 then  s:=s+i;
     if i mod 3=0 then  p:=p*i
    end;
  Writeln ('s=', s, '   p=', p)
end.

2)
var
  i, s, p :integer;
begin
write ('n=');
readln (n);
s:=0;
p:=1;
   i:=1
 while i<= n do
    begin
     if i mod 5=0 then  s:=s+i;
     if i mod 3=0 then  p:=p*i;
     i:=i +1;
    end;
  Writeln ('s=', s, '   p=', p)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?