Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
valuchska
15.02.2020 00:53 •
Информатика
Перевести программы с языка c++ на язык паскаль: 1. int a,b; cin » a»b; a = 2* a; if(a > b){a = 2*b; } else if (a else if(a==b){a = a + b; } cout « a; 2. int x = 64; int y = 40; while(x! =y){ if(x> y){ x = x - y; }else{ x = y-x; } } dct
Ответ:
ангелочек1631
04.10.2020 04:05
1. Полноценная программа
var a,b:integer;
begin
Read(a,b);
a:=2*a;
if a >b then a:=2*b
else
if a<>0 then begin if a=b then a:=a+b end;
Writeln(a)
end.
2. Фрагмент программы
var x,y:intereg;
begin
x:=64; y:=40;
while x<>=y do
if x>y then x:=x-y else x:=y-x;
0,0
(0 оценок)
Популярные вопросы: Информатика
Лида1113внк
06.06.2023 18:37
5. Напишите код программы на языке Python для решения следующей задачи. [4] Задача. «Счастливое число» Будем считать «счастливыми» числа, которые делятся без остатка на 3...
грустнаякакахаха
13.01.2020 22:59
Использу цикл whіlе и fоr, операторы continue, break а) Вывести на экран нечетные числа от 20 до 30. Результат: 21 23 25 27 29...
Tittans104
13.09.2022 12:30
Напишите программный код для следуйщей задачи Составьте программу вычисления математического выражения...
tixon1501
18.01.2021 12:32
Буклет о выставке детского творчества состоит из 520 страниц. часть страниц содержат только текст, а часть содержат только изображения. известно, что: 1. на каждой странице...
Grizzly23
12.10.2020 00:28
Составить программу в алгоритмическом языке. даны действительные числа x, y, z. составьте программу которая находит max(x+y+z, xy/z)...
EgorT222
01.12.2020 05:54
вариант: перевести числа 39 из десятичной системы счисления в двоичную, в восьмеричную, в шестнадцатеричную....
НастяMokrik
11.04.2020 02:34
На рисунке - скемя дорог, связывающих города А, Б, В, Г, Д, Е, И, К, По каждой дороге можно двигаться только в одном направлении, указанном стрелкой, Сколько существует различных...
КРЕНДЕЛЬ228
12.04.2020 11:46
Написать программу которая по введенному номеру дня недели выдавал название дня...
Madinauakhitova
11.05.2022 22:59
Паскаль. Линейный алгоритм. Площадь квадрата....
Fox125123
12.02.2022 01:25
Для ремонта квартиры купили 4 банки краски,по 3 кг каждая.сколько кг.краски купили? составь две обратные и реши их....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,b:integer;
begin
Read(a,b);
a:=2*a;
if a >b then a:=2*b
else
if a<>0 then begin if a=b then a:=a+b end;
Writeln(a)
end.
2. Фрагмент программы
var x,y:intereg;
begin
x:=64; y:=40;
while x<>=y do
if x>y then x:=x-y else x:=y-x;