В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Жека331211
Жека331211
21.08.2021 03:35 •  Информатика

Написать программу си++ задан массив целых чисел вычислить сумму отрицательных элементов этого массива и определить их количество

Ответ:
Xsenia274
Xsenia274
09.08.2020 07:24
#include <iostream>
using namespace std;
int main()
{
int n, sum,howmuch;
sum = howmuch = 0;
cout << "Введите количество элементов массива" << endl;
cin >> n;
int a[n];
for(int i =0; i < n; i++){
cout << "Заполните массив" << endl;
cin >> a[i];
}

for(int i = 0; i < n; i++){
if (a[i] < 0)
{
howmuch++;
sum += a[i];
}
}
cout << "Сумма отрицательных элементов массива:" << sum << endl;
cout <<"Количество отрицательных объектов массива" << howmuch << endl;
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?