В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
valeria232425
valeria232425
15.04.2021 08:25 •  Информатика

C/c++.

найдите наименьший четный элемент массива. если такого нет, то выведите первый элемент.

Ответ:
alinaaubakirova1
alinaaubakirova1
04.10.2020 03:22

#include <iostream>

using namespace std;

int main() {

int n, k=0;

cin>>n;

int arr[n];

for (int i=0; i<n; ++i) {cin>>arr[i]; if (arr[i]%2==0&&(arr[i]<arr[k]||arr[k]%2==1)) k=i;}

cout<<arr[k];

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?