В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
valerunik160val
valerunik160val
15.07.2022 23:17 •  Информатика

Составьте программу которая содержит функцию нахождения количества разрядов заданного числа не превосходящего 1000000000

Ответ:
4elovek20000
4elovek20000
04.10.2020 02:23
Function kr(n:longint):integer;
var
  s:string;
begin
  Str(Abs(n),s);
  kr:=Length(s)
end;

var
  k:longint;
begin
  Write('Введите целое число: '); Read(k);
  Writeln('В этом числе количество разрядов равно ',kr(k))
end.

Пример работы программы
Введите целое число: 1234567
В этом числе количество разрядов равно 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?