В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
furymalice
furymalice
15.07.2022 23:17 •  Информатика

Напишите программу, определяющую количество и сумму элементов массива целых случайных чисел, больших 50 и меньших 60.

Ответ:
maxfum
maxfum
20.08.2020 01:09
Const
  nn=100;
var
  n,i,k,s:integer;
  a:array[1..nn] of integer;
begin
  Write('Количество элементов в массиве: '); Read(n);
  Randomize;
  Writeln('Сформированный массив');
  k:=0; s:=0;
  for i:=1 to n do begin
    a[i]:=Random(100);
    Write(a[i],' ');
    if (a[i] in [51..59]) then begin s:=s+a[i]; Inc(k) end
    end;
  Writeln;
  Writeln('На интервале [51..59] найдено элементов - ',k);
  Writeln('Их сумма равна ',s)
end.

Пример выполнения программы
Количество элементов в массиве: 20
Сформированный массив
26 65 64 80 46 0 54 38 63 14 63 81 40 42 17 16 23 88 61 54
На интервале [51..59] найдено элементов - 2
Их сумма равна 108

Замечание
Если конструкция a[i] in [51..59] кажется незнакомой, её можно заменить на более длинную и менее эффективную (a[i]>50) and (a[i]<60)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?