В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kot291
kot291
14.03.2022 19:47 •  Информатика

Написать программу си++ вот условие : задан массив целых чисел. отсортировать четные элементы массива по возрастанию, а нечетные по убыванию. нужно

Ответ:
fjdjwjqksnddjj
fjdjwjqksnddjj
04.10.2020 01:58
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {const int n=6;
 int arr[n],c;
 for(int i=0;i<n;i++)
  cin>>arr[i];
 for(int i=0;i<n-1;i++)
  for(int j=i+1;j<n;j++)
   if(arr[i]>arr[j] && arr[i]%2==0 && arr[j]%2==0)
    {c=arr[i];
    arr[i]=arr[j];
    arr[j]=c;}
 for(int i=0;i<n-1;i++)
  for(int j=i+1;j<n;j++)
   if(arr[i]<arr[j] && arr[i]%2!=0 && arr[j]%2!=0)
    {c=arr[i];
    arr[i]=arr[j];
    arr[j]=c;}
 cout<<"Array"<<endl;
 for(int i=0;i<n;i++)
  cout<<arr[i]<<" ";
 return 0;}

Пример ввода:
2 6 4 1 5 3
Пример вывода:
Array
2 4 6 5 3 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?