В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
canimzoo
canimzoo
08.03.2020 12:51 •  Информатика

25 ! (составьте программу паскаль) уличный продавец газет получает а рублей с продажи каждой из первых 50 газет. с продажи каждой из остальных газет он получает на 20% больше. вычислите дневной заработок продавца, k газет в день.

Ответ:
Ibrolya
Ibrolya
21.04.2020 08:25
Var
    k: integer;
    a, s: real;

begin
    write('Начальная стоимость: ');
    readln(a);
    write('Число проданных газет:  ');
    readln(k);
    
    if k <= 50 then s := k * a
    else
    begin
        s := 50 * a;
        s := s + (k - 50) * a * 1.2;
    end;
    writeln('Выручка составила  ', s, ' руб.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?