В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
NastyaBay2710
NastyaBay2710
07.12.2022 09:09 •  Информатика

Программа, которая вычисляет сумму всех делителей заданного натурального числа n и находит все нечетные делители этой суммы. входные данные - в первой строке входного файла input.txt cсодержится число n(1< =n< =6*10^8) выходные данные -в выходной файл output,txt вывести все нечетные делители в порядке возрастания. пример - input.txt = 10, output.txt = 1 3 9

Ответ:
правелостиля
правелостиля
04.10.2020 00:23
//PascalABC.NET 3.2 сборка 1318

Var
  f:text;
  n,sum,i:integer;
begin
assign(f,'Input.txt');
reset(f);
read(f,n);
close(f);
for i:=1 to n do
  if n mod i=0 then sum:=sum+i;
assign(f,'Output.txt');
rewrite(f);
for i:=1 to sum do
  if (sum mod i=0) and (odd(i)) then write(f,inttostr(i)+' ');
close(f);
end.

Пример содержимого Input.txt:
4
Пример содержимого Output.txt:
1 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?